نشرت تحت تصنيف Wireless Multicast

12 IGMP Proxy



قبل أن نبدأ في الخوض في شرح IGMP Proxy سنتعرف علي UDL routing , حيث يقوم ULD بالتأثير في عمل بروتوكولات الراوتر في شبكات Multicast و Unicast حيث أن هذه البروتوكولات تقوم بتمرير البيانات الي الواجهات interfaces التي استقبلتها من جهة أخري و هذا السيناريو يحدث فقط في اتصالات ثانئية الإتجاه bidirectional Links المتعارف عليها في غالب الشبكات و هذا بالطبع لن يحدث في شبكات وحيدة الإتجاه مثل شبكات اتصالات الأقمار الصناعية broadcast satellite links التي تعتبر مثال حي و طبيعي عن اتصالات وحيدة الإتجاه و الغير متناسقة مع بروتوكولات الراوتر ثنائية الإتجاه مثل OSPF و Enhanced Interior Gateway Routing Protocol (EIGRP) و بالتالي تؤثر في بروتوكولات Protocol Independent Multicast (PIM) التي تعتمد عليهم

في شبكات unicast routing يقوم الراوتر بتمرير البيانات الي هدفها الوحيد مستخدمة بروتوكول من فئة distance vector مثل EIGRP و ذلك عند تلقيه الطلب لذلك أي اتصال “رايح جاي”

في شبكات Multicast routing بنفس الطريقة يتم طلب الإنضمام لجروب مالتيكاست و من ثم يتم السماح للطلب ثم بشكل عكسي يتم تمرير بيانات هذا الجروب الي طالبيه و هذا أيضا اتصال “رايح جاي”

و لهذا فإن بروتوكولات unicast و multicast لا يتم دعمهم من قبل شبكات UDLR و لهذا فنحن بحاجة الي طريقة أخري تتخطي هذه الصعوبات في شبكات المالتيكاست و هي هنا IGMP Proxy

مثال علي IGMP Proxy


اذن فإن IGMP Proxy يستخدم لتمكين الأجهزة الغير متصلة بـ بالأجهزة downstream من الإتصال بجروب المالتيكاست من شبكة upstream عبر هذا التسلسل

أولا user 1 يرسل طلب انضمام IGMP الي الجروب G

ثانيا الراوتر C يرسل رسالة طلب انضمام PIM الي الراوتر B

ثالثا الراوتر B يستقبل طلب الإنضمام PIM ثم يبحث في جدول mroute

رابعا الراوتر B يقوم بتمرير طلب الإنضمام عبر الإنترنت باستخدام proxies الي الراوتر A متخطيا الإتصال ULD الأحادي

خامسا الراوتر A يقوم ببث التدفقات عبر خط unidirectional link (UDL)

لكي تعمل هذه الخطوات فلابد من وجود الإعدادات التالية

أولا سنقوم بإعداد الجهاز upstream device

Router A Configuration

RouterA(config)# interface gigabitethernet 0/0/0

RouterA(config)# ip address 10.1.1.1 255.255.255.0

RouterA(config)# ip pim dense-mode

RouterA(config)#!

RouterA(config)# interface gigabitethernet 1/0/0

RouterA(config)# ip address 10.2.1.1 255.255.255.0

RouterA(config)# ip pim dense-mode

RouterA(config)# ip igmp unidirectional-link

RouterA(config)#!

RouterA(config)# interface gigabitethernet 2/0/0

RouterA(config)# ip address 10.3.1.1 255.255.255.0

ثانيا سنقوم بإعداد الجهاز Downstream device

Router B Configuration

RouterB(config)# ip pim rp-address 10.5.1.1 5

RouterB(config)# access-list 5 permit 239.0.0.0 0.255.255.255

RouterB(config)#!

RouterB(config)# interface loopback 0

RouterB(config)# ip address 10.7.1.1 255.255.255.0

RouterB(config)# ip pim dense-mode

RouterB(config)# ip igmp helper-address udl ethernet 0

RouterB(config)# ip igmp proxy-service

RouterB(config)#!

RouterB(config)# interface gigabitethernet 0/0/0

RouterB(config)# ip address 10.2.1.2 255.255.255.0

RouterB(config)# ip pim dense-mode

RouterB(config)# ip igmp unidirectional-link

RouterB(config)#!

RouterB(config)# interface gigabitethernet 1/0/0

RouterB(config)# ip address 10.5.1.1 255.255.255.0

RouterB(config)# ip pim sparse-mode

RouterB(config)# ip igmp mroute-proxy loopback 0

RouterB(config)#!

RouterB(config)# interface gigabitethernet 2/0/0

RouterB(config)# ip address 10.6.1.1 255.255.255.0

Router C Configuration

ip pim rp-address 10.5.1.1 5

access-list 5 permit 239.0.0.0 0.255.255.255

!

interface ethernet 0

ip address 10.8.1.1 255.255.255.0

ip pim sparse-mode

!

interface ethernet 1

ip address 10.9.1.1 255.255.255.0

ip pim sparse-mode

نادر المنسي

محاضرات في Multicast

المعلق:

مهندس عربي يطمح و يساعد في الرقي بالمحتوي العربي للتكنولوجيا عبر ترجمة و اعداد مقالات و كتب علمية في مجال الشبكات و الإتصالات السلكية و اللاسلكية

اترك رد

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

شعار وردبرس.كوم

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   /  تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   /  تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   /  تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   /  تغيير )

Connecting to %s