نشرت تحت تصنيف ALL، Wireless Design

مثال عملي لإنشاء شبكة سيسكو لاسلكية


سنقوم في هذه السطور بشرح كيفية عمل شبكة لاسلكية تغطي ثلاث طوابق مع تقسيمها اشارتها الراديوية الي شبكتين أحدهما للمستخدمين في الشبكة و اخري للضيوف

الأجهزة المطلوبة

أولا كابينة شبكة في كل دور

ثانيا سويتش واحد علي الأقل في كل كابينة من نوع 3750X و هو السويتش المعتمد من سيسكو للشبكات اللاسلكية

ثالثا كنترولر واحد من نوع 5500 و يفضل وضعه في الكابينة التي تتوسط الشبكة

رابعا 90 أكسس بوينت من نوع LAP1250 أو أي نوع يتوافق مع الكنترولر 5500

خامسا راوتر و هو اختياري فمن الممكن أن تستعيض عنه بأحد السويتشات السابقة و لكن ان كان موجودا فهو الأفضل

الطبولوجية المكانية

  • لابد أن يكون الكنترولر متوافقا مع الأكسس بوينت فمثلا الكنترولر من نوع 5500 يعمل بنظام 7 و الأكسسبوينت LAP1142N يدعم نظام التشغيل 5 فما فوق لذلك فيستطيع العمل معه و هكذا و تستطيع نعرفة ذلك من موقع سيسكو للجهاز المعني
  • عدد الأكسس بينت لابد أن تكون أقل من عدد بورتات السويتات 3750 لأن كل منها سيربط سلكيا مع بورتات هذه السويتشات
  • يتساوي مع حجم المبني و التغطية المرادة و يفضل أن تكون المسافة بين كل أكسس بوينت لا تقل عن عشرة أمتار(حلول سيسكو تختلف كثيرا عن شركات أخري في موضوع التغطية)
  • ربط الأكسس بوينت ببورتات السويتش ضروري لأخذ الطاقة POE و نقل اعدادات الكنترولر اليه
  • الكابينة التي بها الكنترولر ستحتوي علي سويتش سنسميه السويتش المركزي حيث سيتم ربطه بالراوتر و بباقي السويتشات
  • الكنترولر سيربط فقط بالسويتش المركزي بكابل واحد علي الأقل patch cord عبر uplink
  • يفضل ان تكون أجهزة الأكسس بوينت مربوطة بالسويتش الموجودة في دورها
  • يفضل تفعيل vtp لنشر اعدادات السويتش المركزي الي باقي السويتشات

ان قمت بتغيير بعض من هذه الأجهزة فلابد أن تتاكد من توافقية عملها مع الباقي فمثلا لابد أن تكون فئة الكنترولر متوافقة مع فئة الأكسس بوينت و هذا ستعرفه من جداول مصفوفات سيسكو CISCO Matrix و التي توضح أي من البرمجيات و الأجهزة التي ستعمل سويا ادخل هذه الصفحة

و هذه Cisco Wireless Devices Association Matrix

الطبولوجية المنطقية

بإستخدام الأجهزة السابقة سنقوم ببناء تلك الطبولوجية و سنقوم بربط جميع أجهزة الأكسسبوينت LAP بسويتش مركزي الذي سيعتبر القنطرة التي ستصل الأكسس بوينت بالكنترولر WLC لأخذ إعدادت التشغيل

كل سويتش في كل دور سيقوم بربط أجهزة الأكسس بوينت في هذا الدور

و سيصل السويتش المركزي الأكسس بوينت أيضا بالراوتر الذي سيعتبر البوابة لشبكة الإنترنت

كما تري فإننا سنقوم بعمل شبكتين لاسلكيتين أحداهما للضيوف و الثانية للشبكة اللاسلكية الأساسية و لكل منهما شبكة ظاهرية VLAN لها DHCP server خاص يحدد عنواينهما IP و سيقوم الراوتر بأداء دور سيرفر DHCP

تستطيع أن تستخدم أي جهاز آخر لأداء دور DHCP Server مثل السويتش أو سيرفر خاص أو حتي الكنترولر


الطبولوجية التي أمامك للسويتش المركزي الذي يربط الراوتر بالكنترولر و بباقي السويتشات الأخري الموزعة في الدوار

المعلومات السابقة

سيتطلب منك لمتابعة هذه السطور أن تكون علي معرفة بطريقة إعداد أجهزة الكنترولر WLC و طريقة إعداد DHCP و DNS علي أجهزة سيسكو

سنقوم بإفتراض أنه تم عمل الإعدادت الأساسية للكنترولر و لذلك سنعرج علي صميم إعدادت الشبكة الحالية و أنصحك بزيارة هذه المقالات

 

أنواع Interfaces في WLAN Controller

 

الفرق بين Interface و Port و علاقتهم بـ WLAN في Controller

 

إعداد Controller بواسطة Graphical User Interfaces

عمل الواجهات الديناميكية

هي عمل واجهتين من نوع dynamic interfaces علي الكنترولر واحدة للمستخدم الداخلي للشبكة اللاسلكية و الأخري للضيوف

وستكون إعدادات كل منهما هكذا


قم بفتح واجهة الكنترولر و اتبع التبويب Controllers > Interfaces ليظهر لك واجهات الكنترولر ثم قم بعمل New كما بالشكل


سنبدأ بشبكة الضيوف قم بكتابة مسمي الشبكة و Vlan الخاصة بها ثم اضغط apply


سيقودك هذا الي الصفحة التالية لإستكمال إعداد واجهة Guest مثل port Number و هو البورت الموجود علي الكنترولر و الذي سينقل الكنترولر بواستطه بيانات الضيوف الي السويش

و ستملأ أيضا اعدادت IP التي في الأعلي


بعد مليء الخانات ثم الضغط علي apply سنقوم بإعادة الخطوات السابقة لكن مع مستخدمي الشبكة internal-WLAN


ثم هكذا مثل السابق


ستظهر الواجهتان Dynamics مع أبناء عمومتهم Static هنا في صفحة interfaces


انشاء الشبكات اللاسلكية SSID

سنقوم بانشاء WLAN لكل Interface مما سبق و ذلك من خلال التبويب WLAN ثم قم بإختيار عنوان SSID مناسب للشبكة اللاسلكية


بعد الضغط علي Apply ستأخذك الي اإعدادت WLAN قم بتفعيلها من Status ثم اختر الواجهة التي ستربط guest عليها و هي بالطبع guest-lan

ثم اختر تفعيل نشر SSID ان أردت نشر الشبكة


ثم قم بالدخول الي إعدادت الأمن و التي سنقوم فيها بتفعيل الولوج للضيوف من خلال التوثيق الذي تريد

“أنا بعملها open ” 🙂

هنا فعلنا توثيق الويب و الذي يعني الولوج للشبكة من خلال ادخال كلمة مرور و اسم مستخدم في صفحة ويب و تتم انشاء حسابات للمستخدمين بعدة طرق تستطيع هذه الصفحات أن تفيدك

في كلا الحالتين لابد أن تقوم بعمل حسابات للمستخدمين بواسطة اي تقنية من التقنيات التي تدعمها شبكات سيسكو اللاسلكية و هذه المقالات ستفيدك

 

تحويل الكنترولر لسيرفر لاسلكي RADIUS

السيرفر اللاسلكي LDAP بإستخدام Win 2003 AD

عمل سيرفر توثيق للشبكة اللاسلكية بواسطة RADIUS


سنكرر نفس الخطوات مع internal WLAN


غير أننا سنوقم بإختيار Layer 2 security 802.1x من نوع web


ثم ستظهر لك الشبكات اللاسلكية التي صنعتها مع كافة معاملاتها


قم بتخزين ما صنعته ثم أعد تشغيل الكنترولر كما تري


إعداد السويتش المركزي

سنقوم بعمل إعدادات للسويتش و تتمثل هذه الإعدادات في ضبط منافذ الإتصال مع الكنترولر و الراوتر و التي لابد أن تكون 802.1Q trunk port

و إعدادت Trunk علي السويتش ستحدد VLAN المسموح بمرورها بالإضافة لتحديد Native VLAN و التي سيقوم الكنترولر من خلاله بنقل الإعدادت لأجهزة الأكسس بوينت

و هذا هو إعدادات البورت المتصل بالكنترولر

interface f0/12

Description Connected to the WLC

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport trunk allowed vlan 10,20,60

switchport mode trunk

no ip address

و هذا هو إعدادات البورت المتصل بالراوتر

interface f0/10

Description Connected to the Router

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport trunk allowed vlan 10,20,60

switchport mode trunk

no ip address

أما إعدادت الورتات المتصلة بالأكسس بوينت فستكون من النوع access و ستكون منتمية الي VLAN native و التي هي برقم 60

و هذه الإعدادات ستكررها لكل بورت متصل بأكسس بوينت و يفضل أن تستخدم الأمر interface range ….

interface f0/9

Description Connected to the LAP

Switchport access vlan 60

switchport mode access

no ip address

ملحوظة هامة : ستقوم بتكرار الخطوات اللازمة مما سبق للسويتشات الأخري و يفضل عمل VTP علي السويتش المركزي لنشر اعدادت VLAN

إعداد الراوتر

علي اعتبار أن هذا الراوتر تم اعداه مسبقا ليكون بوابة الشبكة للإنترنت و أن كل اعدادته الخاصة بعمليات التوجيه تم اعدادها فسننتقل للخطوة الرابعة

سنقوم ببث الروح في الشبكة اللاسلكية و ذلك عبر إعداد الراوتر و الذي سيقوم بإعداد كل شبكة بعناوينها من خلال ضبطه كسيرفر DHCP

كذلك سيعمل كبوابة لربط الضيوف بالإنترنت و كذلك لربط مستخدمي الوايرلس مع مستخدمي الشبكة السلكية

الجديد هنا أننا سنقوم بعمل sub-interfaces للبورت المتصل بالسويتش لعمل

سنقوم بحجز العناوين المستخدمة في الشبكة لمنع DHCP من توزيعها

هذا لمنع استخدام عنوان Guest-WLAN

ip dhcp excluded-address 10.0.0.10

هذا لمنع استخدام عنوان f0/0.1 علي الراوتر و الذي يستخدم كبوابة Guest-WLAN من خلال عمله sub-interfaces

ip dhcp excluded-address 10.0.0.50

هذا لمنع استخدام عنوان internal-WLAN

ip dhcp excluded-address 20.0.0.10

هذا لمنع استخدام عنوان f0/0.2 علي الراوتر و الذي يستخدم كبوابة internal-WLAN من خلال عمله sub-interfaces

ip dhcp excluded-address 20.0.0.50

ثم نقوم بعمل سيرفر DHCP لتوزيع عناوين الضيوف مع بيان الراوتر و سيرفر dns

ip dhcp pool Guest

network 10.0.0.0 255.0.0.0

default-router 10.0.0.50

dns-server 172.16.1.1

نكرر نفس الأمر مع شبكة المستخدمين اللاسلكية

ip dhcp pool Internal

network 20.0.0.0 255.0.0.0

default-router 20.0.0.50

ضبط اعدادات منفذ f0/0 للراوتر الذي يربطه مع السويتش و هو منفذ DHCP لكل الواجهات اللاسلكيةو يقع في نفس شبكة wlc managment

interface FastEthernet0/0

description Connected to L2 Switch

ip address 172.16.1.60 255.255.0.0

duplex auto

speed auto

الخطوة الأهم هنا هو عمل sub-interface كمنفذ لكل شبكة لاسلكية و اعطاءها عنوان و هو defaultgatway لكل wlan و هذا ما يخص guest

interface FastEthernet0/0.1

description Guest VLAN

encapsulation dot1Q 10

ip address 10.0.0.50 255.0.0.0

اما هذا فهو internal

interface FastEthernet0/0.2

description Internal VLAN

encapsulation dot1Q 20

ip address 20.0.0.50 255.0.0.0

الخطوة الأخيرة

بمجرد انتهائك فستجد أن الشبكات اللاسلكية أصبحت متوفرة لأي جهاز لاسلكي بمسمي guest و internal

بالنسبة ل guest فمجرد فتح الانترنت ستظهر صفحة التوثيق هذه


بينما شبكة internal و التي كانت توثيقها بـ WEP ستدخل بباسورد طبيعي

نادر المنسي


Advertisements

المعلق:

مهندس عربي يطمح و يساعد في الرقي بالمحتوي العربي للتكنولوجيا عبر ترجمة و اعداد مقالات و كتب علمية في مجال الشبكات و الإتصالات السلكية و اللاسلكية

رأيان على “مثال عملي لإنشاء شبكة سيسكو لاسلكية

اترك رد

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

شعار وردبرس.كوم

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   /  تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   /  تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   /  تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   /  تغيير )

w

Connecting to %s